WOW !! MUCH LOVE ! SO WORLD PEACE !
Fond bitcoin pour l'amélioration du site: 1memzGeKS7CB3ECNkzSn2qHwxU6NZoJ8o
  Dogecoin (tips/pourboires): DCLoo9Dd4qECqpMLurdgGnaoqbftj16Nvp


Home | Publier un mémoire | Une page au hasard

 > 

Etude d'une offre technique innovante de téléphonie sur IP à  Camtel Cameroun


par Soulemanou Nsangou Moungnutou
Université de Maroua Cameroun - Ingénieur en télécommunications et réseaux 2012
  

Disponible en mode multipage

Bitcoin is a swarm of cyber hornets serving the goddess of wisdom, feeding on the fire of truth, exponentially growing ever smarter, faster, and stronger behind a wall of encrypted energy

DEDICACES

Je dédie ce mémoire aux personnes qui me sont les plus chers et dans l'ordre des choses principalement à mon défunt papa Mr el adj. MOUNGNUTOU MAMA qui aurait tout donné pour voir le résultat de mon travail mais dont la vie et le sort en ont décidé autrement.

Ma deuxième pensé va profondément à ma mère Mme MOUNGNUTOU CHETOU qui dans les moments les plus difficiles a toujours su être à la hauteur des événements constituant ainsi le pylône de la famille.

Je dédis également ce mémoire à tous mes frères et soeurs de mon grand frère Mr NGOUPAYOU MOUNGNUTOU ISSOFA au benjamin MOUNGNUTOU ABOUBAKAR SIDIKI

Je ne pourrais clore cette section sans mettre en relief le rôle prédominent qu'a joué ma fiancée Mlle LOUMGAM MELAINE FLORE et dont les conseils et le soutient moral ont été d'une incommensurable importance.

REMERCIEMENTS

Mes sincères remerciements vont :

Ø Tout d'abord, aux membres du jury :

- Prof.Dr.-Ing.habil KOLYANG pour avoir présidé ma soutenance ;

- Dr ELOUNDOU NTSAMA Pascal pour avoir examiné mon travail.

- Dr MOHAMADOU BALLO pour avoir bien voulu participé à ma soutenance en tant que rapporteur

- Ing-Pleg DONGMO LADEM Fabrice Ludovic

Ø Ensuite au personnel administratif ainsi que les professeurs de l'Institut Supérieur du Sahel de Maroua ISS. En particulier le Dr OLIVIER VIDEME BOSSOU pour sa disponibilité et tous les sacrifices qu'il consent pour la formation de ses étudiants.

Ø Egalement à :

- Monsieur l'ingénieur BIKANDA VALERE, pour sa disponibilité et son encadrement sur le plan professionnel durant la réalisation de ce travail.

- Mr Vivaldi Perlin pour son aide logistique et professionnelle

- A tous mes camarades de l'Institut supérieure du Sahel de Maroua pour le soutient et la solidarité dont ils ont fait preuve pendant toutes ces années de formation.

J'adresse enfin ma reconnaissance et toute ma gratitude envers tous ceux qui, de près ou de loin ont contribué d'une façon ou d'une autre à mon édification et à ma réussite académique.

RESUME

Le secteur des télécommunications est sans doute celui dont les innovations sont les plus spectaculaires, de la téléphonie fixe parut au milieu du 19ieme à la téléphonie mobile parut à la fin du 20ieme siècle les télécommunications se sont diversifiées par l'arrivée de l'informatique qui est devenue la véritable plateforme des échanges économiques culturels et sociaux . le nouveau concept à explorer serait de fusionner l'informatique et la téléphonie afin de pouvoir réaliser un réseau unique qui offrirait en terme d'avantage moins de contrainte de maintenance , de sécurité, et permettrait de bénéficier des tarifs de communication très commodes .

C'est donc dans le but de proposer une architecture de communication unifiée voix/données que s'est axé notre travail à l'entreprise de télécommunication CAMTEL. CAMTEL opérateur historique du Cameroun, dispose d'un réseau RTCP en mode TDM utilisant les signalisations SS7 TUP/ISUP, un réseau IP fourni par l'intermédiaire du backbone IP/MPLS , et un réseau NGN en pleine structuration reposant sur le coeur du réseau IP/MPLS pour la couche transport et possédant une couche adaptation comprenant des passerelles appelées média Gateway permettant la conversion en IP de tous les flux RTCP GSM CDMA , afin de les acheminer au coeur du réseau intelligent appelé couche contrôle commandée par l'équipement softswich .

La téléphonie sur IP TOIP est un service qui répond aux normes d'innovation , et de convergence d'application comme la voix, les données , la messagerie instantanée, les SMS , la messagerie vocale , le fax etc...

En nous appuyant sur le model NGN de CAMTEL La conception des offres techniques de TOIP comme l'offre VPN/TOIP pour les entreprises multi sites et les offres de TOIP pour abonnés simples souscrivant à des abonnements internet seront les principaux axes de notre travail.

ABSTRACT

The telecommunication sector is probably the sector where innovations are the most spectacular, since fixed telephony appeared in the mid 19th century to the mobile phone appeared in the late 20 th century telecommunications are diversified by the arrival of the computer that became the real platform of cultural and social economic exchanges.

The new concept to explore is to merge computing and telephony in order to achieve a unique network that would provide less benefit in terms of constraint maintenance, security, and would benefit rates very convenient communication.
This is in order to offer a unified communications architecture voice / data that has focused our work in CAMTEL Telecommunications Company.

CAMTEL incumbent Cameroon network, has a PSTN mode TDM SS7 signaling using TUP / ISUP, an IP network provided through the backbone IP / MPLS and NGN network structure based on the core of the network IP / MPLS transport layer and having a layer adaptation including gateways called Media Gateway to the conversion of all IP flows GSM CDMA RTCP to transport them to the core of the intelligent network control layer controlled by the equipment called softswich.

TOIP IP telephony is a service that meets the standards of innovation and convergence of application such as voice, data, instant messaging, SMS, voicemail, fax etc ...

Building on the model of NGN CAMTEL design offers TOIP techniques such as offering VPN / TOIP for multi-site enterprises and offers simple TOIP for subscribers subscribing to internet subscriptions will be the main focus of our work.

TABLE DES MATIERES

INTRODUCTION GENERALE 1

CHAPITRE I CONTEXTE PROBLEMATIQUE ET METHODOLOGIE 3

1 - PRESENTATION DE CAMTEL ET SECTEUR D ACTIVITE 3

1.1. PRESENTATION DE L'OPERATEUR CAMTEL. 3

1.1.1 Historique 3

1.1.2 Son activité 5

1.1.2.1 Offre aux particuliers 5

_Toc335406886 1.1.2.2 Offre aux entreprises 3

1.1.3 Ses données clés 7

1.1.4 Organisation administrative 7

1.2.1 Les réseaux d'interconnexion des sites d'entreprises déployés par CAMTEL 9

2 CONTEXTE 10

3 PROBLEMATIQUE...........................................................................................................................11

4 OBJECTIFS........................................................................................................................................12

5 APPROCHE METHODOLOGIQUE 12

CHAP II GENERALITES 13 C:\Users\SOULEYMANE\Desktop\NSANGOU.docx - _Toc335406897

Introduction 3

1 les réseaux de communication 14

1-1 le réseau téléphonique commuté 14

1-1-1 Architecture et principe de fonctionnement 14

1-1-2 Structure d'un central téléphonique 15

1-1-2 Les protocoles de signalisation dans le RTCP 16

1-2 La téléphonie mobile 17

1-2-1 Le GSM 17

1-2-1-1 Les infrastructures du GSM 18

1-2-1-2 Les avancées de la téléphonie mobile 20

1.3 Le réseau internet 20

1.3.1Les différents types de réseaux informatiques 20

1.3.2 Les protocoles du réseau internet : les models TCP/IP et OSI 20

1.3.4 le routage IP 21

1. 3.4.1 Notion d'adresse IP et de masque de sous réseau (IPV4 et IPV6 ) 21

1.2.5 Fonctionnement d'internet 21

1.4 Fusion de la téléphonie et d'internet 22

1.4.1 Les techniques XDSL 22

1.4.1.1 comparaisons des différentes techniques XDSL 22

1.4.1.2 ADSL avantages et inconvénients 25

1.4.2 La téléphonie sur IP 26

1.4.2.1 Principe de fonctionnement 26

1.4.2.2 Les éléments de la TOIP 27

1.4.2.3 réalisations d'un réseau de TOIP 31

1.5 Les réseaux de nouvelle génération (NGN) et la TOIP 35

1.5.1 Définition 35

1.5.2 Les différents types de NGN 35

1.5.3 Architecture des réseaux NGN 36

1.5.4 Les équipements du coeur de réseau NGN 37

1.5.5 Les familles de protocoles des réseaux NGN 38

1.5.5.1 Les protocoles de control d'appel 38

1.5.5.2 Les protocoles de commande de Media Gateway 3

1.5.5.3 Les protocoles de signalisation entre les Softswitchs 41

1.5.6 La téléphonie dans les NGN 41

1.5.6.1 Les NGN classe 5 41

1.5.6.2 Le NGN classe 4 42

1.5.7.1 Etude d'un MSAN : le MSAN d'Alcatel-Lucent ( ISAM-V) 43

CHAP II CONCEPTION DE LA SOLUTION TOIP /CAMTEL dans le NGN.....................................45

1 PRESENTATION DES RESEAUX RTCP IP et NGN de CAMTEL 46

1.1Présentation du réseau RTCP de CAMTEL 46

1.1.1 Inventaire des différents équipements et infrastructures 46

1.2 Le NGN de CAMTEL 46

1 .2.1 équipements et infrastructure 46

1.2.2 Description d'un NGN : le NGN ZTE 48

1.2.3 Les limites du NGN CAMTEL 49

1.3 Le réseau IP de CAMTEL 50

1.3.1 Les limites du réseau IP de CAMTEL 51

2 CONCEPTION DE LA SOLUTION TOIP DE CAMTEL 51

2.1 Au niveau de l'opérateur CAMTEL 51

2.2 Au niveau de l'abonné 53

2.3 : ARCHITECTURE DE LA SOLUTION TOIP CAMTEL 53

CHAP IV LA TOIP CAMTEL OFFRES TECHNIQUES INNOVANTES 56

C:\Users\SOULEYMANE\Desktop\NSANGOU.docx - _Toc335406990 1 Etude de l'offre innovante de TOIP 3

1.1avantages pour CAMTEL 57

2 étude de l'offre innovante TOIP aux grandes structures 57

2.1 Approche physique et théorique des VPN 57

2.1.1 Les protocoles des VPN de CAMTEL 58

1.1.2 Avantages économiques de l'offre innovante de VPN /TOIP 59

3 avantages pour les particuliers 59

4 applications de l'offre innovante de VPN/TOIP CAMTEL : cas du MINESUP 60

4.1 SIMULATION 60

4.2 Logiciels de Simulation 60

4.3 Présentation de la maquette de simulation 63

4-4-1 configurations des routeurs 65

4.4.2 Conception et configuration des machines virtuelles 77

4.4.3 Connexion des machines virtuelles de VMware avec la maquette de GNS3 77

4.5 Configuration des comptes sur TRIXBOX 78

CHAP V RESULTATS ET COMMENTAIRES 82

1 .vérification de l'implémentation des protocoles de routage OSPF BGP LDP EIGRP 82

1.1 Vérification d'OSPF 82

1.2 Vérification de BGP.............................................................................................83

1.3 Vérification d'EIGRP............................................................................................84

1.4 Vérification de MPLS à travers LDP........................................................................................................... 85

2. vérification de la bonne implémentation de la TOIP dans le VPN /TOIP 86

MINESUP 86

3. Commentaires 88

_Toc335407064 4 Conclusion et perspectives....................................................................................90

LISTE DES TABLEAUX

Tableau 1 avantages et inconvénients des VPN........................................................................................... 3

Tableau 2 : comparaison des techniques XDSL.............................................................................................. 22

Tableau 3 : comparaison de SIP et H323........................................................................................................ 28

Tableau 4 :Score MOS....................................................................................................................................... 29

Tableau 5 : codec et leur rôle........................................................................................................................... 30

Tableau 6 : récapitulatif des solutions PBX et leurs fonctionnalités........................................................... 31

Tableau 7: récapitulatifs des solutions soft phones.................................................................................... 32

Tableau 8 images de quelques soft phones................................................................................................... 33

Tableau 9 Tarifs entreprise proposés par CAMTEL....................................................................................... 59

Tableau 10: tarifs pour simple abonné CAMTEL.......................................................................................... 60

LISTE DES FIGURES

Figure 1: le câble SAT3/WASC/SAFE 3

Figure 2:Organigramme structurel de CAMTEL 8

Figure 3:Exemple de réseau d'entreprise. 9

Figure 4 : téléphone fixe prémière génération 14

Figure 5 : architecture RTCP 15

Figure 6 schéma de la signalisation 16

Figure 7 architecture de ss7 17

Figure 8 : Architecture en cellules du GSM 17

Figure 9 : antenne BTS du GSM 18

Figure 10 : antenne BTS du GSM 18

Figure 11:exemple de réseau internet 21

Figure 12 : exemple de réseau IP 21

Figure 13:exemple de test de connectivite entre deux machines du réseau 22

Figure 14 architecture ADSL 23

Figure 15 Modems ADSL SAGEM 23

Figure 16 DSLAM Alcatel + filtrage Alcatel et DSLAM Huwei 24

Figure 17 : BRAS ALCATEL 24

Figure 18 :architecture ADSL avant NGN 24

Figure 19 schéma ADSL avant NGN 25

Figure 20 : processus de traitement de la voix 27

Figure 21 interface du soft phone X-lite 33

Figure 22 passerelle GSM interconnectant le GSM et le PSTN 34

Figure 23 réseau TOIP d'entreprise 35

Figure 24 : architecture NGN 37

Figure 25: architecture H323 39

Figure 26 : Architecture de SIP 40

Figure 27 : Architecture NGN classe 5 42

Figure 29 : utilisation de la carte NPOT 43

Figure 28:architecture NGN classe 4 43

Figure 30 :rôle des cartes NVPS 44

Figure 31 : Cabinet MSAN d'ALCATEL -LUCENT 44

Figure 32 diagramme de liaison du CTI/YDE avec la plaque forme NSOFT 47

Figure 33: Topologie du NGN ZTE 49

Figure 34: Réseau IP de CAMTEL 50

Figure 35 plan RTCP de CAMTEL avec les plates formes NGN 51

Figure 36 : PLATEFORME TOIP CAMTEL 54

Figure 37 adaptation d'un PABX en IP-PBX 55

Figure 38 : Exemple du VPN du ministère de la défense 58

Figure 39 : interface graphique de GNS3 61

Figure 40 : Interface graphique de VMware 62

Figure 41 : interface graphique de TRIXBOX 63

Figure 42: maquette de simulation conçue sur GNS3 64

Figure 43:interface présentant les cartes réseaux virtuelles sur GNS3 78

Figure 44 :l'interface de TRIXBOX 79

Figure 45 : création des comptes utilisateur sur le serveur trixbox 80

Figure 46:configuration des soft phones 81

Figure 47 : trafic entre P1etPE1 82

Figure 48:trafic entre P1 et PE2 83

Figure 49: trafics entre PE1 et CE1 84

Figure 50:protocole LDP capturé dans les trames 85

Figure 51:téléphone-IP du MINESUP/ YDE affichant son numéro 86

Figure 52 : Téléphone -IP de la délégation régionale du MINESUP de l'extrême Nord UMA/ISS affichant son numéro 87

Figure 53 : capture de la signalisation SIP entre le serveur et MINUSUP/ISS 88

Figure 54: courbe de trafic du VPN /TOIP MINESUP 89

GLOSSAIRE

A

ADSL : Asymétric Digital Suscriber Line

ATM: Asynchronous Transfer Mode

ADSL: Asymmetrical Digital Subscriber Line

AS: Application Server

B

BTS : Base station transceiver

BSS : Base station subsystem

BGP: border gateway protocol BSC: base station controler

C

CDMA: Code Division Multiple Acces

CAMTEL: Cameroon Telecommunications

D

DSLAM : Digital Suscriber Line Access Multiplexer

DCE : Data Circuit terminal Equipment

DSP : Digital Signal Processeur

DNS : Domain Name Serveer

E

ETTD : Equipement Terminal de Traitement des Données

EIGRP : Enhance internet gateway routing protocol

F

FCS: Frame Sheck Sequence

FEC: forwarding equivalent class

G

GSM: Global System for Mobile Communications

I

IP: Internet Protocol

IETF: Internet Engineering Task Force

IP-PBX: Internet Protocol-Private Branch eXchange

IOS: Internetworking Operating System

ISUP:

L

LS: Ligne Spécialisée

L2VPN: Level two Virtual Private Network

LAN: Local Area Network

LDP: Label distribution protocol

M

MPLS: Multiprotocol Label Switching

MLPS-TE : Multiprotocol Label Switching traffic ingeniering

MINPOSTEL: Ministère des Postes ET télécommunications

MGCP: Media Gateway Control Protocol

MAC: Medium Access Control

MG: Media Gateway

MSAN: Multiservice access Node

N

NGN: Next Generation Network

O

OSS: Operating SubSystem

OSPF : open short path first

P

PPTP: Point to Point Tunneling Protocol

PABX : Private Automatic Branch eXchange

PDP

R

RTC : Réseau Téléphonique Commuté

RNIS : Réseau Numérique à Intégration des Services

RTP: Real-Time Protocol

RTCP: Real Time Control Protocol

S

SIP: Session Initiation Protocol

SS7: SIgnalling Semaphore 7

SIGTRAN: Signalling transport

T

TDM: Time Division Multiplexing

TOIP: Telephone Over Internet Protocol

TUP : telephone User path

U

UMTS: Universal Mobile Telecommunications Systems

URAD: unite de raccordement d'abonnées distant

UIT: Union Internationale des Telecommunications

UDP: User Datagrams Protocol

V

VRF : virtual routing forwarding

VPN: Virtual Private Network

VSAT: Very Small Aperture Terminal

VOIP: Voice over Internet Protocol

W

WAN: Wide Area Network

 

INTRODUCTION GENERALE

A L'aube du 21ième siècle, les télécommunications ont connu un essor spectaculaire .Dans ce domaine, l'heure est à la fois à la qualité de service et également à la multiplicité des offres apportée aux consommateurs.

D'une manière générale, si le RTCP et le RNIS sont les médias propices pour le transport de la voix, il n'en demeure pas moins que le transport des données à travers le protocole TCP/IP prend le pas sur ces derniers.

Le nouveau concept est donc de rêver d'un réseau unique où circuleront les services suivants voix /vidéo/donnés

La TOIP s'inscrit donc dans cette logique des réseaux de nouvelles générations appelés réseaux (NGN) (next génération network).

CAMTEL opérateur historique du Cameroun a pour devoir et ambition de modifier son architecture afin de proposer des gammes variées de services.

De la téléphonie classique offerte à travers le RTCP et la téléphonie mobile par CDMA , CAMTEL a su se doter d'une part d'un Backbone IP/MLPS qui assure l'interconnexion du Cameroun et du monde à travers le câble SAT3 rendant ainsi possible la fourniture de service internet à haut débit et d'autre part d'un NGN construit avec des équipements HUAWEI et ZTE .

Le présent mémoire a pour but de faire l'étude d'une offre technique innovante de téléphonie sur IP à CAMTEL.

Il comporte cinq chapitres :

Le premier chapitre : présente les préambules nécessaires à la compréhension de notre thématique.

Le second chapitre évoque quant à lui les généralités de notre sujet, il a pour but de faire l'état de l'art sur le domaine de la TOIP y compris des rappels et des données existantes.

Le chapitre 3 est dédié à la conception de la solution TOIP de CAMTEL : Il a pour but de présenter la solution que nous proposons à CAMTEL pour la TOIP

Le chapitre 4 : récence les différentes offres de TOIP que CAMTEL pourrait proposer à savoir l'offre de VPN/TOIP et les offres de TOIP pour simples abonnés, les avantages économiques.

Le chapitre 5 sert à détailler les résultats de notre étude en vue de faire un commentaire exhaustif

La dernière partie a pour but de faire une conclusion générale et de d'énoncer quelques perspectives pour améliorer les services de TOIP dans les réseaux NGN

CHAPITRE I

CONTEXTE PROBLEMATIQUE OBJECTIFS

ET APPROCHE METHODOLOGIQUE

1 - PRESENTATION DE CAMTEL ET SECTEUR D ACTIVITE

1.1. PRESENTATION DE L'OPERATEUR CAMTEL.

Description

CAMTEL (Cameroon Télécommunications) est l'opérateur historique du secteur des télécommunications au Cameroun. C'est une société d'État au capital de 50.000.000.000 FCFA détenu à 100% par l'État camerounais, créée par Décret N° 98/198 du 08/09/98 dans le cadre de la restructuration du secteur des télécommunications qui faisait suite à la Loi N° 98/014 de la 14/07/98 portante libéralisation dudit secteur.

1.1.1 Historique

CAMTEL est née en 1998 de la transformation de la direction des Télécommunications (Ministère des postes et télécommunications) en société anonyme à laquelle s'ajouta l'entreprise publique IntelCam, alors en charge des communications téléphoniques internationales. La filiale de téléphonie mobile, Camtel-Mobil, fut vendue à l'opérateur de Télécommunication MTN en février 2000.Ces changements sont intervenus lors de la libéralisation du secteur des télécommunications au Cameroun.

En 2005, la société CAMTEL a lancé le service de téléphonie Mobile CT-Phone, basée sur la technologie CDMA. Au cours de l'année 2009, elle a enfin acquise une licence GSM (principal attrait des investisseurs). Pour ce qui est de la fourniture d'accès Internet, après l'arrimage du Cameroun au réseau transcontinental du système SAT3/WASC/SAFE (South Atlantic câble N°3/West African Submarine Cable/South Africa Far East) en 2003, CAMTEL a largement densifié son offre Internet aussi bien aux particuliers qu'aux entreprises, parmi lesquelles de nombreux fournisseurs d'accès.

Figure 1: le câble SAT3/WASC/SAFE

Avec le déploiement de la fibre optique sur le territoire national (plus de 5600 km de longueur prévu), CAMTEL a mis sur pieds une dorsale nationale encore de transmission en pleine expansion et appelée « Backbone IP MPLS », qui plus tard sera utilisée par tous les opérateurs des télécommunications installé au Cameroun, et surtout qui lui facilite déjà la mise en place de ses réseaux d'entreprises.

1.1.2 Son activité

L'entreprise CAMTEL est l'opérateur public de téléphonie au Cameroun. Au rang des services qu'il fournit, on peut citer principalement :

q La téléphonie fixe (Avec ou sans fil).

q La téléphonie mobile type CDMA (Offre « City Phone »)

q Internet.

q Les réseaux d'Entreprises (lignes spécialisées, VSAT, VPN).

Ces principaux services sont offerts sous deux formes :

l Offre aux particuliers

l Offre aux entreprises.

1.1.2.1 Offre aux particuliers

L'offre aux particuliers regroupe principalement trois services : la téléphonie, l'accès Internet ; les services internet.

Ø La téléphonie

Le service de téléphonie regroupe trois principales offres :

· Le fixe filaire.

· Le CT Phone.

· La télécopie (Fax).

Ø L'accès Internet

Le réseau Internet est accessible par deux noeuds d'accès au backbone international à Douala et Yaoundé à travers le câble sous-marin SAT3 pour un débit total de 933Mb/s (soient 622Mb/s à Douala et 311Mb/s à Yaoundé).

Ce débit est appelé à croître dans un futur proche compte tenu de la demande sans cesse croissante. Les principaux moyens d'accès à Internet offerts par CAMTEL aux particuliers sont : l'ADSL, et le Wireless.

Ø Les services Internet

Les services Internet offerts sont de quatre types :

· L'allocation des noms de domaine (.tv, .org, .biz, .net, ...).

· La création des sites Internet.

· L'hébergement des sites web.

· E-mail perso.

Tous ces services constituent les offres proposés aux particuliers.

1.1.2.2 Offre aux entreprises

Les offres aux entreprises sont cataloguées comme suit :

o Solution Téléphonie fixe

§ Offre préférentielles.

§ Numéro vert.

o Solution internet

§ ADSL haut débit.

§ Sites et applications web.

§ Hébergement professionnel.

o Réseaux d'Entreprise

§ LS Nationales.

§ LS Internationales.

§ Faisceau hertzien (VSAT, ...).

§ VPN.

1.1.3 Ses données clés

L'entreprise exploite les principaux produits suivants :

Téléphone fixe : environ 250.000 lignes (principal source de revenus de CAMTEL).

CT-Phone : environ 500.000 lignes (sur 13.000.000 de lignes mobiles au Cameroun).

1.1.4 Organisation administrative

Placée sous la tutelle du MINPOSTEL (Ministère des Postes et Télécommunications), CAMTEL est dotée d'un Conseil d'Administration composé de :

§ Un président

§ Six membres représentants l'état

§ Un membre représentant le personnel

§ Un membre représentant la commission technique de privatisation et des liquidations

 
 
 
 
 
 
 
 

Ce conseil se prononce régulièrement (en conseils ordinaires et extraordinaires) sur les grandes orientations stratégiques de l'entreprise. La gestion quotidienne de la société est assurée par un Directeur Général assisté de deux Directeurs Généraux adjoints.

Direction Générale

Administration Centrale

Délégation Urbaine de Douala

Services rattachés

Direction Technique de Yaoundé

Service des réseaux d'accès radio

Services Extérieurs

BSS

NSS

WIN

CCRA-CDMA

SVA

SSM

Bureau d'Ordre

Figure 2: Organigramme structurel de CAMTEL

DT

S.DRAF

SDD

SDRIP

SDEE

Notre séjour dans l'entreprise s'est effectué dans le service des réseaux IP SDRIP qui est l'une des directions de l'administration centrale de CAMTEL. Cette Direction assure le déploiement et la gestion du backbone fibre optique ainsi que la fourniture des services internet

1.2 Les réseaux d'entreprises à CAMTEL et leurs défis actuels.

Les réseaux d'entreprises permettent, de manière plus restreinte qu'Internet, soit de relier plusieurs sites distants d'une même entreprise (Intranet), soit d'ouvrir un lien entre 2 entreprises distinctes ayant conclu un accord (Extranet), soit alors d'ouvrir le réseau privé d'une entreprise à la clientèle (Réseau d'accès).

Figure 3:Exemple de réseau d'entreprise.

1.2.1 Les réseaux d'interconnexion des sites d'entreprises déployés par CAMTEL

Les services de Réseaux d'Entreprise que l'opérateur de Télécommunications CAMTEL offre à sa clientèle s'appuient principalement sur les technologies suivantes :

- Les VSAT : qui consistent en une interconnexion de sites distants à l'aide d'antennes paraboliques à faible ouverture par l'intermédiaire du relais satellite Intelsat.

- Les liaisons spécialisées (LS : en fibre optique ou en cuivre) qui permettent l'interconnexion de plusieurs sites distants d'un client par des lignes privées dédiées.

Les VPN (Virtual Private Network) sur fibre optique, qui est une technique d'extension des réseaux locaux qui préserve la sécurité logique que l'on peut avoir à l'intérieur d'un réseau local.

Tableau 1 avantages et inconvénients des VPN

Avantages des VPN

Inconvénients des VPN

· Coût assez réduit.

· Mise en oeuvre relativement rapide.

· Flexibilité

· Bon niveau de disponibilité.

· Pas de réelle garanties performances (sauf pour les VPN MPLS)

· Plus de compétence pour la maintenance.

2 CONTEXTE

Le Cameroun est le pays le plus peuplé de l'Afrique centrale. Cet avantage démographique est un facteur prédominant à prendre en compte dans le déploiement de nouveaux services dans la recherche des marchés.

Malgré sa forte démographie , le Cameroun est néanmoins un pays pauvre où l'accès aux services de télécommunication tels Internet , la Téléphonie fixe , L` ADSL relève encore pour beaucoup d'un véritable Luxe car leurs revenus mensuel ne le leur permet pas . CAMTEL opérateur national de télécommunication a pour rôle et devoir d'adapter ses produits à la conjoncture camerounaise afin qu'aucun camerounais quel que soit son revenu et sa situation géographique ne puisse être à l'écart.

C'est dans cet optique que CAMTEL désire faire une étude d'une offre innovante de téléphonie et d'internet moins contraignante que l'on appelle la Téléphonie sur IP en anglais TOIP .

La TOIP est une offre convergente où les paquets voix sont encapsulés dans les trames IP ce type de transfert de la voix rend la téléphonie moins chère accessible à toute personne qui a une simple connexion internet .

CAMTEL disposant d'un réseau RTCP , IP  et nouvellement d'un réseau NGN voudrais se hisser au premier ordre dans la conquête de ce nouveau marché qui est la TOIP offre qui aura pour but de relancer et motiver les populations pour acquérir les connexions internet

3. PROBLEMATIQUE

§ CAMTEL ne dispose pas encore de services de TOIP car son réseau NGN bien que ayant un coeur en IP est encore en plein structuration.

§ la TOIP est un service temps réel, il nécessite par conséquent des protocoles temps réel tel RTP, RTCP .

§ La TOIP étant un service de téléphonie il nécessite des protocoles de signalisation de le VOIP tel H323 et SIP

§ la TOIP nécessite également des serveurs d'appel, des IPBX, des passerelles vers d'autres réseaux

§ La TOIP nécessite en autre des serveurs de messagerie pour les SMS

La problématique est donc de savoir si le NGN de CAMTEL peut être modifié et comment pour permettre la TOIP

4 OBJECTIFS

Nous avons comme principal objectif :

Aboutir, au terme de ce travail, à la conception d'une solution NGN pour une offre innovante de la téléphonie sur IP dans la gamme des services à valeurs ajoutés proposés par CAMTEL répondant aux normes des réseaux de nouvelle génération à savoir :

Ø L'accessibilité

Ø La qualité de service QoS

Ø La sécurité

Ø La mobilité

Ø Le coût moyen répondant à la conjoncture du Cameroun

5 APPROCHE METHODOLOGIQUE

Notre méthodologie se subdivise en plusieurs étapes :

Ø imprégnation du réseau CAMTEL à travers le passage dans certains services techniques de Yaoundé afin de d'avoir un bref a perçut de l'existant

Ø étude comparative des offres techniques convergentes de téléphonie et d'IP tel l'ADSL

ï limites relevées.

ï Inventaires des équipements et infrastructures

Ø étude d'une offre technique innovante de TOIP dans le réseau CAMTEL d'après le plan suivant:

Ø Description et évaluation des équipements à mettre en oeuvre.

Ø Architecture de l'offre TOIP.

Ø Apports innovants que permet l'adressage IPV6

Ø Problèmes à prévoir et limites

Ø diverses actions à mener en cas de panne

Simulation de l'offre TOIP à travers les plates formes GNS3 VMWARE TRIXBOX X-LITE

CHAP II

GENERALITES

Introduction

La communication est l'ensemble des procédés par lesquels les individus échangent des informations de près ou de loin. Les mutations sans cesse croissant du monde ont favorisé l'essor de ce domaine qui sans attendre est passé au stade de la télécommunication. La télécommunication est le fait de communiquer à grande ou courte distance en utilisant des procédés radios électriques ou électromagnétiques. Le besoin pour des organisations gouvernementales de communiquer en toute confidentialité a très vite poussé à la création des entités dites réseaux de télécommunication d'abord à des buts militaires et la demandes civile étant plus croissante ont été étendues à toute classe de population On voit ainsi naitre différents réseaux dont la topologie et la typologie sont imposées par la nature et les contraintes des services souhaités. Parmi ces réseaux on peut citer le réseau de téléphonie et le réseau internet

1 les réseaux de communication

1-1 le réseau téléphonique commuté

Le Canadien Alexandre Graham Bell fut l'inventeur de la téléphonie. Dans son début la téléphonie fut analogique et nécessitait l'utilisation des lignes téléphoniques et des postes analogiques de première génération.

Il s'agissait de la téléphonie fixe dont les premiers téléphones sont les suivant

Figure 4 : téléphone fixe première génération


1-1-1 Architecture et principe de fonctionnement

Le réseau RTCP présente une architecture hiérarchisée en couche formée des éléments suivants :

Ø les centres locaux (CL) : qui traitent le trafic local d'une zone

Ø les centres à autonomie d'acheminement (CAA) : qui raccordent les CAA

Ø Les centres de transit secondaires (CTS) qui interconnectent les CAA

Ø les centres de transit principaux qui interconnectent les (CTP) qui interconnectent les CTS

251653120

Figure 5 : architecture RTCP

1-1-2 Structure d'un central téléphonique

Un central téléphonique est constitué des équipements de transmission et des équipements de commutation.

Ø Les équipements de transmission

Dans ces équipements on peut citer les supports de transmission ( fibre optique , cuivre , faisceaux hertziens ) et les équipements de multiplexage à savoir les ADM

(Addrop Multiplexer). Les antennes VSAT dans certains cas.

Ø Les équipements de commutation

Pour la commutation, on a l'autocommutateur qui comprend les organes suivants :

· L'organe de commutation (SN)

· L'organe de liaison (LTG)

· L'organe de mémoire (MB)

· L'organe de contrôle (CCP)

Dans le cas des commutateurs locaux on a des unités de raccordement d'abonnés (DLU)

1-1-2 Les protocoles de signalisation dans le RTCP

Définition de la signalisation

Pour définir la notion de la signalisation, nous avons consulté plusieurs dictionnaires, en résumant toutes les définitions, on a pris celle qui nous a parue la plus exhaustive :

La signalisation c'est : Ensemble de messages de service échangés entre les commutateurs de réseau ou entre ceux-ci et les équipements des utilisateurs, qui sont nécessaires à l'établissement et à la gestion des communications ; ces messages portent sur l'état des liaisons du réseau et sur la nature des équipements des utilisateurs.[1]

La signalisation concerne tous les échanges d'informations nécessaires pour la fourniture et la maintenance d'un service de télécommunications.

La signalisation comprend les signaux requis pour la gestion des connexions:

· Etablissement et rupture

· Contrôle et facturation

· Supervision et maintenance

Gestion GSM et IN (Intelligent Network

Figure 6 schéma de la signalisation

communication

établissement

rupture

contrôle

Ø SS7 : le protocole de signalisation du RTCP

De nos jours le protocole utilisé est SS7 (signalisation sémaphore 7) il divisé en cinq couches

· TUP (Telephone user parth) utilisé dans les pays comme ( le Brésil,la Chine, les USA)

· ISUP (ISDN user parth) utilisé en Europe et au Cameroun

· SCCP (signaling connection control parth)

· TCAP( transaction capabilities application parth)

Figure 7 architecture de ss7

1-2 La téléphonie mobile

1-2-1 Le GSM GSM est l'acronyme de (global system for mobile télécommunication) c'est le système de téléphonie mobile paru au milieu des années 90 . Le GSM repose sur une architecture cellulaire dans laquelle le territoire est divisé en cellule

Figure 8 : Architecture en cellules du GSM

1-2-1-1 Les infrastructures du GSM

Dans un réseau GSM, le terminal de l'utilisateur est appelé station mobile. (MS) .Une station mobile est composée d'une carte SIM (Subscriber Identity Module), permettant d'identifier l'usager de façon unique et d'un terminal mobile, c'est-à-dire l'appareil de l'usager (la plupart du temps un téléphone portable). [2]

Les terminaux (appareils) sont identifiés par un numéro d'identification unique de 15 chiffres appelé IMEI (International Mobile Equipment Identity). Chaque carte SIM possède également un numéro d'identification unique (et secret) appelé IMSI (International Mobile Subscriber Identity). Ce code peut être protégé à l'aide d'une clé de 4 chiffres appelés code PIN.

La carte SIM permet ainsi d'identifier chaque utilisateur, indépendamment du terminal utilisé lors de la communication avec une station de base. La communication entre une station mobile et la station de base se fait par l'intermédiaire d'un lien radio, généralement appelé interface air (ou plus rarement interface Um. Les MS communiquent directement avec des stations de base (BTS) .

Figure 9 : antenne BTS du GSM

L'ensemble des stations de base d'un réseau cellulaire est relié à un contrôleur de stations (en anglais Base Station Controller, noté BSC), chargé de gérer la répartition des ressources.
L'ensemble constitué par le contrôleur de station et les stations de base connectées constituent le sous-système radio (en anglais BSS pour Base Station Subsystem).

Enfin, les contrôleurs de stations sont eux-mêmes reliés physiquement au centre de commutation du service mobile (en anglais MSC pour Mobile Switching Center), géré par l'opérateur téléphonique, qui les relie au réseau téléphonique public et à internet. Le MSC appartient à un ensemble appelé sous-système réseau (en anglais NSS pour Network Station Subsystem), chargé de gérer les identités des utilisateurs, leur localisation et l'établissement de la communication avec les autres abonnés.

Le MSC est généralement relié à des bases de données assurant des fonctions complémentaires :

· Le registre des abonnés locaux (noté HLR pour Home Location Register): il s'agit d'une base de données contenant des informations (position géographique, informations administratives, etc.) sur les abonnés inscrits dans la zone du commutateur (MSC).

· Le Registre des abonnés visiteurs (noté VLR pour Visitor Location Register): il s'agit d'une base de données contenant des informations sur les autres utilisateurs que les abonnés locaux. Le VLR rappatrie les données sur un nouvel utilisateur à partir du HLR correspondant à sa zone d'abonnement. Les données sont conservées pendant tout le temps de sa présence dans la zone et sont supprimées lorsqu'il la quitte ou après une longue période d'inactivité (terminal éteint).

· Le registre des terminaux (noté EIR pour Equipement Identity Register) : il s'agit d'une base de données répertoriant les terminaux mobiles.

· Le Centre d'authentification (noté AUC pour Autentication Center) : il s'agit d'un élément chargé de vérifier l'identité des utilsateurs.

Le réseau cellulaire ainsi formé est prévu pour supporter la mobilité grâce à la gestion du handover, c'est-à-dire le passage d'une cellule à une autre.

1-2-1-2 Les avancées de la téléphonie mobile

Le GSM est la génération 2 de la téléphonie mobile on l'appelle 2G . il possède des avancées telle le 2.5 GPRS , 2.75 EDGE et le 3.0 UMTS . Dans la téléphonie mobile, on peut aussi citer le CDMA utilisé à CAMTEL

1.3 Le réseau internet

Internet est un ensemble d'ordinateurs interconnectés dans le monde et qui échangent des informations.

1.3.1Les différents types de réseaux informatiques

On distingue différents types de réseaux (privés) selon leur taille (en terme de nombre de machines), leur vitesse de transfert des données ainsi que leur étendue. Les réseaux privés sont des réseaux appartenant à une même organisation. On fait généralement trois catégories de réseaux :

· LAN (local area network)

· MAN (metropolitan area network)

· WAN (wide area network)

Il existe deux autres types de réseaux : les TAN (Tiny Area Network) identiques aux LAN mais moins étendus (2 à 3 machines) et les CAN (Campus Area Network) identiques au MAN (avec une bande passante maximale entre tous les LAN du réseau).

1.3.2 Les protocoles du réseau internet : les models TCP/IP et OSI

Internet repose sur deux models à savoir le model TCP/IP et le model OSI et les protocoles tel : TCP IP DHCP DNS FTP http SMTP UDP RTP 1.3.3 les protocoles et leurs utilités En informatique les protocoles servent à faire fonctionner plusieurs logiciels ou services on distingue :

Ø FTP pour les transferts de fichiers

Ø HTTP pour les pages Web

Ø DNS pour la résolution des noms de domaine

Ø DHCP pour la configuration des adresses IP

Ø UDP pour le transport des paquets

Ø TCP pour le contrôle

1.3.4 le routage IP L'acheminement des paquets se fait grâce aux adresses IP et aux masques de reseau

1. 3.4.1 Notion d'adresse IP et de masque de sous réseau (IPV4 et IPV6 )

On distingue deux types d'adresses IP : les adresses IPV4 et IPV6.

Les adresses IPV4 sont codées sur 32 bits et sont un ensemble de quatre chiffres variant de 0 à 255 et permettent d'identifier une machine dans le monde Ex 194.165.18.23

Les Adresses IPV6 ont 128 bits et sont codées en hexadécimal Ex fedc:482:cafe:ba05:a200:e8ff: fe65:a

1.2.5 Fonctionnement d'internet 

251654144 Nous allons prendre le cas du routage entre deux LAN d'adresses respectives 193.150.3.0 et 193.150.4.0

251658240

Figure 10 : exemple de réseau IP

Figure 11: exemple de test de connectivite entre deux machines du réseau

de test de connectivite entre deux machines du réseau 1.4 Fusion de la téléphonie et d'internet

1.4.1 Les techniques XDSL

Le XDSL est l'ensemble des technologies qui permettent la transmission des données haut débit sur une ligne RTCP . On distingue des solutions symétriques et asymétriques dépendantes des facteurs tels : la vitesse de transmission , le débit abonné et fournisseur la portée du signal [3]

1.4.1.1 comparaisons des différentes techniques XDSL

Les différentes techniques XDSL sont consignées dans le tableau suivant

Tableau 2 : comparaison des techniques XDSL

1.4.1.1 L ADSL : principe de fonctionnement

L'intérêt de la technologie ADSL est qu'elle tire parti des bandes de fréquence non utilisées par le téléphone. Ainsi, alors que la voix est transportée sur une bande de fréquence allant de 300 à 3400Hz (rappelons que la bande de fréquence audible va de 20Hz à 20kHz), le signal ADSL est transmis sur les plages de fréquences hautes, inaudibles, de 25,875kHz à 1,104MHz. L'utilisation de cette bande très large permet de transporter des données à des débits pouvant atteindre 8Mbit/s au maximum en réception et 768Kbit/s en émission (d'où le A de ADSL qui signifie asymétrique). Point intéressant pour l'utilisateur, les signaux voix et ADSL utilisant des plages de fréquences différentes, la même ligne téléphonique permet de téléphoner et de surfer sur Internet à débit très rapide simultanément. L'ADSL utilise l'architecture suivante :

Figure 12 architecture ADSL

Les éléments essentiels de l'architecture de l'ADSL sont :

Ø Le modem ADSL appartenant au client qui sert à accéder à internet

Figure 13 Modems ADSL SAGEM

Ø Le filtre ADSL qui permet filtrer la voix des données

Ø Le DSLAM qui est équipement de l'opérateur et qui sert de multiplexeur des signaux des abonnés

Figure 14 DSLAM Alcatel + filtrage Alcatel et DSLAM Huwei

Ø Le BAS ou BRAS est l'équipement du réseau qui fait l'interface entre le réseau de

collecte et le RBCI (réseau Backbone et de collecte IP). Le routage IP, l'authentification des abonnés et le comptage des volumes de trafic sont effectués par l'intermédiaire de ce serveur large bande [4]

Figure 15 : BRAS ALCATEL

Figure 16 schéma ADSL avant NGN

1.4.1.2 ADSL avantages et inconvénients

Ø LES INCONVENIENTS

Voici la liste des inconvénients de la technologie ADSL :


· L'ADSL n'est pas encore disponible dans la totalité du territoire (moins de 3O% du territoire camerounais est couvert) ;


· Le débit affiché bien que plus rapide que par un modem 56k reste souvent théorique au vu des problèmes de diaphonie et de la qualité de la paire de cuivre ;


· Il est nécessaire de se situer dans une zone compatible et proche d'un centre. Les campagnes sont alors exclues de ce mode de communication. La dissipation d'énergie est à l'origine de cette contrainte ;


· au Cameroun, pour bénéficier de l'ADSL, il est nécessaire d'avoir un abonnement téléphonique.

· La portée da L'ADSL est d'environ seulement 5km

Ø LES AVANTAGES

L'ADSL présente de nombreux avantages par rapport à une connexion Internet classique :


· L'ADSL permet des débits beaucoup plus important ;


· La plupart des offres ADSL sont des offres illimitées ;


· La connexion est permanente et la ligne téléphonique est libérée ;


· L'installation est facile : le client est en mesure de l'effectuer lui-même, cela ne nécessite pas d'intervention de la part du fournisseur d'accès, elle est donc à moindre coûts ;


· Le haut débit a permis l'apparition de nombreux services : tels que la vidéo, la téléphonie sur IP, la télévision sur IP ...

Pour l'opérateur, l'ADSL ne nécessite pas un investissement trop onéreux, le dernier kilomètre par l'ADSL est moins cher que l'utilisation de la fibre optique. L'utilisation du réseau téléphonique existant permet d'envisager un grand nombre d'abonnés potentiels. L'ADSL est toujours en pleine expansions .

1.4.2 La téléphonie sur IP

Face à la demande croissante du haut débit informatique et téléphonique et aux inconvénients posés par l'ADSL, la nécessité de la création d'un réseau unique s'est posée . La TOIP ( Téléphone Over Internet Protocol) est le fruit de la convergence de internet et de la téléphonie

1.4.2.1 Principe de fonctionnement

La téléphonie sur IP est l'application commerciale de la voix sur IP . La voix sur IP est le transport de la voix à travers le réseau internet . Son principe de fonctionnement est basé sur le schéma ci-desous :

Figure 17 : processus de traitement de la voix

Les étapes de traitement de la voix sont : [5]

Ø Echantillonnage à 8khz et quantification

Ø Codification : chaque échantillon est codé sur 8bits grâce à un CAN (convertisseur analogique numérique) qui fixe le débit de transmission à 64Kb/s.

Ø Compression à l'aide d'un processeur DSP qui réduit le débit grâce à des codecs G711 , G728 , G729,G723, etc... permettant un débit de sortie allant de 5,3Kbi/s à 16kb/s.

Ø Suppression du silence pour libérer au maximum la bande passante

Ø Enfin on habille les paquets de voix avec les en-têtes IP, UDP, RTP

RTCP et les injecte dans le réseau IP

1.4.2.2 Les éléments de la TOIP

Ø Les protocoles de signalisation

La TOIP fonctionne grâce à des protocoles de signalisation tels H 323 et SIP :

· H323 est une proposition L'ITU-T qui est en fait une suite de protocoles, il spécifie les composants protocoles et procédures permettant la mise en place d'un service multimédia sur des réseaux à paquets commutés sans garantie de bande passante [5]

· SIP est une proposition de l'IETF c'est un protocole de signalisation appartenant à la couche application du modèle OSI et il est apparenté au protocole HTTP. Son rôle est d'ouvrir, modifier et libérer les sessions. L'ouverture de ces sessions permet de réaliser de l'audio ou vidéoconférence, de l'enseignement à distance, de la voix (téléphonie) et de la diffusion multimédia sur IP essentiellement.

Tableau 3 : comparaison de SIP et H323

Ø Les codecs

Codecs veut dire (codeurs décodeurs) ce sont des scripts permettant de comprimer les flux audios et vidéos . [6]

On distingue deux types de codecs à savoir :

v Codec lossless ici tout le signal est transformé en binaire et le décodage restitue les donné parfaitement identique a celles des données d'entée ce codec est utilisé quand la qualité de la restitution est importante.

v Codec lossy s'agissant du codec lossy certaines partie du signal son purement supprimées par exemple l'oreilles humaine n'écoute pas les fréquences trop basses ou trop élevées le codec lossy tronque ses signaux afin de les adapter a l'oreille humaine

Dans le domaine de la téléphonie sur IP, les différents codecs retransmettent plus ou moins bien le signal original. Pour mesurer la qualité de la voix restituée, on parle de score MOS (Mean Opinion Score). C'est une note comprise entre 1 et 5 et attribuée par des auditeurs jugeant de la qualité de ce qu'ils entendent et dont les résultats sont consigné dans le tableau voir tab (4)

Tableau 4 : Score MOS

Le type de codec le plus approprié pour la VOIP est donc le codec type Lossy et en ce sens il existe plusieurs codec cité dans le tableau ci contre en fonction du détail dans le traitement de l'information

Tableau 5 : codec et leur rôle

CODECRAISON D'UTILISATIONScore MOS

G.711Tout premier codec a avoir été utilisé de nos jour dépassé mais continu à être utilisé pour établir compatibilité entre marques qu'équipement différent le flux produit par ce codec est 64 Kbits/s

4,2G .722Transforme la fréquence du spectre jusqu'à 7khz

Pour un débit fournit de 48,56 ou 64Kbits/s une de ses particularité est de pouvoir immédiatement changer le débit ceci est appréciable lorsque la qualité du support de transmission ce dégrade

G.722 .1Dérivé du codec précédent, celui ci propose des débits encore plus faibles (32 ou 24kbit/s). Il existe même des versions propriétaires de ce codec fournissant un débit de 16kbit/s.

G.723.1C'est le codec par défaut lors des communications à faible débit. Deux modes sont disponibles. Le premier propose un débit de 6,4kbit/s et le deuxième un débit de 5,3kbit/s. Là aussi, le changement de mode peut se faire en pleine communication.

Ce codec est un parfait exemple de codec à pertes. Les tonalités DTMF (utilisée par exemple lors d'un appel à un serveur vocal lorsque l'on appuie sur les touches) ne sont pas correctement retransmises et donc non reconnues.

Les scores MOS.

entre 3,7 et 3,9

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

1.4.2.3 réalisations d'un réseau de TOIP

La réalisation d'un réseau local de TOIP nécessite la mise en place d'une architecture centralisée fonctionnant en mode client/serveur comprenant

Ø Les serveurs de téléphonie IP-PABX

Dans cette optique nous pouvons avoir plusieurs choix de serveurs de téléphonie VOIP dont les principaux sont récapitulés dans le tableau suivants :

Tableau 6 : récapitulatif des solutions PBX et leurs fonctionnalités

Ø Les clients

Pour les clients, nous avons des terminaux physiques (hard phones ou IP phones), analogiques et logiciels (soft phones) .

Parmi les softphones on peut citer ceux représentés par le tableau suivant

Tableau 7: récapitulatifs des solutions soft phones

Figure 18 interface du soft phone X-lite

Tableau 8 images de quelques soft phones

Ø Les passerelles

En plus de ces deux éléments il faut prévoir les passerelles vers les réseaux RTCP et RNIS

Les passerelles VoIP permettent de connecter votre PABX ou IPBX (standard téléphonique IP SIP), ou vos téléphones analogiques au réseau Internet.

· Celles pourvues d'interfaces FXS permettent de connecter des téléphones analogiques ou des lignes extérieures (deux fils) d'un PABX à un réseau local IP ou Internet.

· Celles pourvues d'interfaces FXO permettent de connecter les lignes internes (deux fils) d'un PABX à un réseau local IP ou Internet, ou de se connecter à la place d'un téléphone analogique deux fils.

· Celles pourvues d'interfaces PRI T1/E1 (T2) ou BRI (T0) permettent de connecter les lignes numériques d'un PABX ou d'un opérateur à un réseau local IP ou Internet.

· Celles équipées de modules GSM permettent de se connecter via un réseau opérateur GSM. Avec des passerelles GSM/PRI E1 /T1on peut interconnecter des réseaux GSM aux réseaux RTCP

D'autres permettent d'utiliser des terminaux sans fil de type DECT/GAP d'être vus comme des téléphones SIP depuis Asterisk

Figure 19 passerelle GSM interconnectant le GSM et le PSTN

Figure 20 réseau TOIP d'entreprise

La TOIP dans la pratique dévient difficile lorsqu'on dispose d'un réseau étendu c'est donc dans l'optique de concevoir des réseaux multiservices capable d'interfacer tout type de technologie RTCP, RNIS, IP TV que sont batis les réseaux NGN

1.5 Les réseaux de nouvelle génération (NGN) et la TOIP

1.5.1 Définition

Les réseaux NGN en anglais (next génération network) sont des réseaux de nouvelle génération qui par leur architecture permettent les applications multimédias voix/vidéos/données et dont la cible est le tout IP

1.5.2 Les différents types de NGN

Il existe trois types de NGN :

Les NGN classe 3, classe 4 et classe 5.

Les NGN classe 4 et classe 5 sont les NGN téléphonie et les NGN classe 3 sont les NGN multimédia [7]

1.5.3 Architecture des réseaux NGN

Les réseaux NGN présentent une architecture en cinq couches :

Ø La couche accès :

Elle est constituée des équipements d'accès tels :

· Les BTS pour le GSM et le CDMA

· 251655168Les DSLAM pour l'ADSL

· Les MSAN pour la TVIP et la TOIP

· Les URAD pour le RTCP

Ø La couche transport / adaptation

Elle est responsable de l'acheminement du trafic voix ou données dans le coeur de réseau IP, selon le protocole utilisé. L'équipement important à ce niveau dans une architecture NGN est le « Media Gateway » (MGW) responsable de l'adaptation des protocoles de transport aux différents types de réseaux physiques disponibles (RTC, IP, ATM, ...)

Ø La Couche contrôle

Cette couche gère l'ensemble des fonctions de contrôle des services en général, et de contrôle d'appel en particulier pour le service voix. L'équipement important à ce niveau dans une architecture NGN est le serveur d'appel, plus communément appelé «softswitch », qui fournit, dans le cas de services vocaux, l'équivalent de la fonction de commutation

Ø La couche service ou application

L'ensemble des fonctions permettant la fourniture de services dans un réseau NGN. En termes d'équipements, Cette couche regroupe deux types d'équipement les serveurs d'application (ou application servers) et les « enablers », qui sont des fonctionnalités, comme la gestion de l'information de présence de l'utilisateur, susceptibles d'être utilisées par plusieurs applications. Cette couche inclut généralement des serveurs d'application SIP (Session Initiation Protocol), car il est utilisé dans une architecture NGN pour gérer des sessions multimédias en général, et des services de voix sur IP en particulier.

1.5.4 Les équipements du coeur de réseau NGN

Le réseau NGN présentant une architecture en couche dispose des équipements suivants :

Ø Le Softswitch

Dans une infrastructure NGN, un softswitch n'est autre qu'un serveur informatique, doté d'un logiciel de traitement des appels vocaux. Le trafic voix est en général paquetisé par le media Gateway, et pris en charge par les routeurs de paquets du réseau de l'opérateur. Un softswitch va identifier les paquets voix, analyser leur contenu pour détecter le numéro vers lequel ils sont destinés, confronter ces numéros avec une table de routage (qui indique ce que le softswitch doit faire en fonction de chaque numéro), puis exécuter une tâche (par exemple transmettre ou terminer)

Ø Le Media Gateway

Les media Gateway constituent le deuxième élément essentiel déployé dans un réseau NGN. Un media Gateway peut par exemple se positionner entre le réseau de commutation circuit et le réseau de commutation de paquets. Dans ce cas, les media Gateway transforment le trafic circuit TDM en paquets, la plupart du temps IF, pour que ce trafic puisse ensuite être géré par le réseau NGN.

L'architecture physique du réseau NGN et ses protocoles est la suivante :

Figure 21 : architecture NGN

1.5.5 Les familles de protocoles des réseaux NGN

On peut classer les protocoles de control des réseaux NGN en trois catégories :

· Les protocoles de control d'appel

· Les protocoles de commande des Médias Gateway

· Les protocoles de signalisation entre les serveurs de contrôle

1.5.5.1 Les protocoles de control d'appel

Ils permettent l'établissement, d'une communication entre deux terminaux ou entre un terminal et un serveur ; les deux principaux protocoles concurrents sont H.323, norme de l'UIT et SIP, standard développé à l'IETF. Étudions leurs spécifications respectives:

v La recommandation H.323

La recommandation H.323 décrit les procédures pour les communications audio et vidéo sur des réseaux en mode paquet sans garantie de service.

Les principales entités nécessaires à la réalisation d'un service de communication multimédia sur des réseaux de données sont :

ü Les terminaux H.323 qui sont des systèmes multimédia (téléphone, PC) permettant de communiquer en « temps réel » ;

ü Le Gatekeeper qui gère les terminaux H.323 (identification et traduction d'adresses) et les établissements d'appels ;

ü La passerelle H.323 ou Gateway H.323 qui permet d'interfacer le réseau IP avec le réseau téléphonique classique.

ü unité de contrôle MCU (Multipoint Contrôler Unit) qui gère les connexions multipoints (Exemple : appels de conférence. Il se décompose en un MC (Multipoint Contrôler), affecté à la signalisation, et un MP (Multipoint Processor) dédié à la transmission proprement

Figure 22: architecture H323

v SIP

SIP (Session Initiation Protocol) est un protocole de signalisation défini par l'IETF (Internet Engineering Task Force).

SIP définit deux types d'entités: les clients et les serveurs. Plus précisément les entités définies par SIP sont :

ü Le serveur proxy (Proxy server) : Il reçoit des requêtes de clients qu'il traite lui-même ou qu'il achemine à d'autres serveurs après avoir éventuellement réalisé certaines modifications sur ces requêtes.

ü Le serveur de redirection (Redirect server) : Il s'agit d'un serveur qui accepte des requêtes SIP, traduit l'adresse SIP de destination en une ou plusieurs adresses réseau et les retourne au client. Contrairement au Proxy server, le Redirect server n'achemine pas de requêtes SIP. Dans le cas d'un renvoi d'appel, le Proxy server a la capacité de traduire le numéro de l'appelé dans le message SIP reçu, en un numéro de renvoi d'appel et d'acheminer l'appel à cette nouvelle destination, et ce, de façon transparente pour le client origine ; pour le même service, le Redirect server retourne le nouveau numéro (numéro de renvoi) au client origine qui se charge d'établir un appel vers cette nouvelle destination.

ü L'agent utilisateur (UA, User Agent) : Il s'agit d'une application sur un équipement de l'usager qui émet et reçoit des requêtes SIP. Il se matérialise par un logiciel installé sur un PC, sur un téléphone IP ou sur une station mobile UMTS (UE, User Equipment).

ü L'enregistreur (Registrar) ; Il s'agit d'un serveur qui accepte les requêtes SIP REGISTER.

SIP dispose de la fonction d'enregistrement d'utilisateurs. L'utilisateur indique par un message REGISTER émis au Registrar, l'adresse où il est joignable (e.g., adresse IP), le Registrar met alors à jour une base de donnée de localisation. L'enregistreur est une fonction associée à un Proxy server ou à un Redirect server. Un utilisateur peut s'enregistrer sur différents UAs SIP ; dans ce cas, l'appel lui sera délivré sur l'ensemble de ces UAs.

Figure 23 : Architecture de SIP

1.5.5.2 Les protocoles de commande de Media Gateway

Ces protocoles ont été engendrés par la séparation des couches Transport et Contrôle et permettent au Softswitch de gérer les Media Gateway. MGCP de l'IETF et MEGACO ou H.248, développés conjointement par l'UIT et l'IETF, prédominent actuellement . Ces protocoles représentent le canal de communication utilisé pour coordonner le plan Contrôle et le plan Transport.

Les principales fonctions de ce canal sont :

ü La réservation des ressources de la MG par le MGC nécessaire pour satisfaire les demandes reçues par les messages de signalisation.

ü Le traitement des connexions dans les MG par le MGC ;

ü La remontée par les MG des réponses aux actions demandées par le MGC

ü La notification par le MG d'événements survenus au niveau média

ü Le contrôle du lien MG-MGC (sécurité du lien, basculement vers un autre MGC ou

MG)

1.5.5.3 Les protocoles de signalisation entre les Softswitchs

L'interconnexion des réseaux de données avec les réseaux existants TDM utilisant la signalisation SS7, a nécessité le développement de protocoles dédiés à l'interconnexion des réseaux et au transport de la signalisation SS7 sur des réseaux en mode paquet.

Ces protocoles permettant la gestion du plan contrôle. Ce sont essentiellement

ü BICC (Bearer Independent Call Control)

ü SIP-T (SIP pour la Téléphonie)

ü H.323, au niveau du coeur de réseau ;

ü SIGTRAN (SIGnalling Transport), à l'interconnexion avec les réseaux de signalisation SS7, généralement via des passerelles de signalisation ou Signalling Gateway

1.5.6 La téléphonie dans les NGN

Comme on l'a dit plus haut les NGN classe 4 et 5 sont les NGN téléphonie ils résultent de la migration des réseaux RTCP .

1.5.6.1 Les NGN classe 5

Ils sont obtenus par la migration des commutateurs de classe 5 que sont les commutateurs de liaison .en effet, les classes 5 sont remplacés par les softswichs et les média Gateway afin de rendre le trafic final en IP .l'équipement d'accès final est le MSAN qui est un équipement tout IP. L'accès au service de VOIP se fait directement par le MSAN au cas où on souscrit au service VOIP.

Son architecture est la suivante :

Figure 24 : Architecture NGN classe 5

1.5.6.2 Le NGN classe 4

Le trafic entre commutateurs d'abonnés TDM traditionnels est en fait détourné sur une infrastructure VOIP. Pour cela, l'opérateur connecte ses commutateurs d'abonnés à des Gateway VOIP et des softswitchs de classe 4

Figure 25:architecture NGN classe 4

1.5.7 L'équipement d'accès dans le NGN : le MSAN

Les MSAN constituent une évolution naturelle des DSLAM. Un MSAN est un équipement qui constitue, dans la plupart des architectures de type NGN, un point d'entrée unique vers les réseaux d'accès des opérateurs. A la différence d'un DSLAM, dont le châssis ne peut supporter que des cartes permettant de proposer des services de type xDSL, un MSAN peut supporter des cartes RNIS, Ethernet,... De ce fait, au sein d'un seul et même châssis, l'opérateur peut déployer toutes les technologies d'accès envisageables sur son réseau. Le rôle de media Gateway décrit ci-avant peut, dans certains cas, être « embarqué » au sein de ce MSAN, et disparaître en tant que noeud de réseau dédié. [8]

1.5.7.1 Etude d'un MSAN : le MSAN d'Alcatel-Lucent (ISAM-V)

Le MSAN ISAM-V étend les fonctionnalités du DSLAM par l'ajout des nouvelles cartes à savoir :

· La carte NPOT : La carte du service de la voix traditionnelle

· La carte NBAT : La carte du service RNIS

Ces deux cartes font la conversion de la ligne Analogique à la VoIP

Figure 26 : utilisation de la carte NPOT

· La carte NVPS : La carte qui fait la signalisation avec le softswitch et avec les cartes LT

Figure 27 : rôle des cartes NVPS

La carte NVPS peut faire la signalisation pour plusieurs cartes LT même pour ceux qui n'appartiennent pas au même MSAN (il s'agit des MSAN chainés ou distants)  .

Figure 28 : Cabinet MSAN d'ALCATEL -LUCENT

CHAP III CONCEPTION DE LA SOLUTION TOIP DE CAMTEL DANS LE

NGN

Introduction

Le Cameroun, pays émergent à l'horizon 2035, a pour principal devoir et ambition d'opérer une véritable métamorphose de son secteur industriel. La réalisation de cet objectif passe prioritairement par le développement de son secteur des télécommunications.

Dans les chapitres qui ont précédé, nous avons exposé les principales technologies auxquelles aspire le monde des télécommunications parmi lesquelles la TOIP véritable plateforme de communication à moindre coût pour les particuliers et les entreprises.

Il sera donc question par la suite à la lumière des concepts vus précédemment de satisfaire le cahier de charge suivant :

ï Description et évaluation des équipements à mettre en oeuvre pour la TOIP.

ï Architecture de l'offre TOIP dans le NGN

ï Apports innovants que permettra l'adressage IPV6 en terme de sécurité et de mobilité

ï Problèmes à prévoir et limites

ï diverses actions à mener en cas de panne

· Etude l'aspect financier de l'offre TOIP

Par la suite, la recherche de la solution passera par les étapes suivantes :

Ø Présentation du réseau RTCP de CAMTEL avec les plates formes NGN ZTE et HAWEI.

Ø Présentation du réseau IP de CAMTEL.

Ø Limites relevées

Ø Présentation de la solution TOIP conçue dans le NGN de CAMTEL

Ø Enumérations des offres innovantes en TOIP à savoir les offres TOIP entreprises et TOIP abonnés simples.

Ø Simulation sur GNS3 d'une connexion VPN avec insertion de la VOIP

Ø Implémentation d'IPV6 et analyse de l'apport de ce dernier en termes de mobilité, sécurité, et qualité de service.

1 PRESENTATION DES RESEAUX RTCP IP et NGN de CAMTEL

1.1Présentation du réseau RTCP de CAMTEL

1.1.1 Inventaire des différents équipements et infrastructures

251657216Le réseau RTCP de CAMTEL est un réseau en plein mutation entre le RTCP classique et le NGN .

Depuis quelques années, la migration vers le NGN ne cesse de s'accentuer.

Il possède :

v deux centres de transit nationaux (CTN) situés à Yaoundé et à Douala qui gèrent les communications nationales

v deux centres de transit internationaux (CTI) à Yaoundé et à douala pour les communications internationales et qui relient les deux (CTN)

1.1 Le NGN de CAMTEL

1 .2.1 équipements et infrastructure

Les CTN sont des commutateurs à autonomie d'acheminement qui collectent les trafics des commutateurs locaux des zones locales de Douala et Yaoundé

Ces commutateurs sont des centraux de téléphonie équipés pour la plus part des équipements Siemens EWSD et E10MT20 Alcatel fonctionnant en signalisation SS7 TUP ou ISUP permettant alors la gestion du trafic national

La migration vers le NGN a débuté avec les CTI où les commutateurs E10MT20 d'ALCATEL ont été remplacés par une plate forme NSOFT C (conçue par le fabriquant NSOFT) afin de faciliter des appels internationaux.

v Cette plate forme NSOTF est en réalité un sotfswich qui permet de faire passer certain appels dans certains pays en TOIP elle permet également

· La visioconférence

· la messagerie vocale

· le call limit

· les SMS

· bref tous les services de téléphonie classique, et fonctionne sur les protocoles SIP

Figure 29 diagramme de liaison du CTI/YDE avec la plaque forme NSOFT

Ensuite, la migration c'est opéré dans les CTN.

v à YAOUNDE, le CTN situé à la poste centrale dispose du centre de jonction urbaine qui gère deux boucles locales.

· La boucle MORA (ZTE et HAWEI) interconnectant les centraux de NKOMO, BIYEM-ASSI, JAMOT, et le CTI.

· La boucle METROPOLITAINE interconnectant : BIYEM-ASSI, NKOLBISON, CTN, JAMOT, et NKOMO

Dans l'ancienne architecture le CTN avec le commutateur SIEMENS EWSD interconnectait tous les centraux de la région du centre à savoir BIYEM-ASSI, YAOUNDE CENTRE 2 , JAMOT , NKOMO, NKOLBISON et même d'autres régions le grand NORD , l'EST , le SUD sauf KRIBI et les télé centres communautaires . Mais avec la venue du NGN, on a :

v Le NGN ZTE qui interconnecte NKOMO, BIYEM-ASSI, et DOUALA

v Le NGN HAWEI qui interconnecte BAFOUSSAM, BAMENDA, et JAMOT

1.2.2 Description d'un NGN : le NGN ZTE

Le NGN ZTE de Yaoundé est au centre softswich de CAMTEL dans les locaux du CTI mais est indépendant de la plateforme C du NSOFT il comprend :

· Un softswich

· Une média Gateway

· 2 plates formes d'opération et de maintenance

· Un serveur de Billings

· Des serveurs d'application

Coté réseau on a :

· Deux routeurs Cisco

· Deux Switch Cisco

· Des MSAN à NKOMO et BIYEM-ASSI

Le NGN ZTE de DOUALA est basé au CTN de Douala à Bépanda

1.2.3 Les limites du NGN CAMTEL

Les limites du NGN peuvent être résumées ci-dessous :

ü Existence des centraux TDM qui compliquent l'acheminement IP

ü Non déploiement complète des équipements d'accès tel les MSAN

ü Perte de ligne entrainant les débits faibles sur les boucles locales

ü Non interconnexion réelle des NGN HAWEI et ZTE car tout les trafics entre ZTE et HAWEI passe par les CTN qui sont en TDM

ü Existence des équipements NGN qui n'intègrent pas certain services à valeurs ajoutées : car les MSAN actuels ne sont pas équipés des cartes VOIP

ü Existence des régions entières comme l'ADAMAOUA, le NORD , l'EXTREME NORD , l'EST le SUD , le SUD OUEST et une grande partie de l'ouest qui sont carrément coupées du NGN et utilisent des systèmes de commutation Siemens EWSD génération 11 ou 15 .

Figure 30: Topologie du NGN ZTE

1.3 Le réseau IP de CAMTEL

Comme nous l'avons dit dans le contexte, CAMTEL tire son réseau IP du câble SAT3 /WASC/SAFE et dispose d'un bakbone IP/MPLS qui est rattaché depuis peu de temps au réseau RTCP et CDMA par les NGN ZTE et HAWEI ce rattachement a pour but essentiel de décongestionner le trafic voix au coeur des réseaux RTCP et CDMA en pratiquant de la voix sur IP jusqu'aux MSAN

Figure 31: Réseau IP de CAMTEL

1.3.1 Les limites du réseau IP de CAMTEL

Le réseau IP de CAMTEL présente des problèmes de déploiement et de sécurité .

Avec les topologies ZTE et HAWEI on obtient le plan ci-dessous du réseau de CAMTEL

251656192

Figure 32 plan RTCP de CAMTEL avec les plates formes NGN ZTE et HAWEI

2 CONCEPTION DE LA SOLUTION TOIP DE CAMTEL

Nous pouvons présenter la solution TOIP de CAMTEL à plusieurs niveaux 

2.1 Au niveau de l'opérateur CAMTEL

q Remplacement des anciens commutateurs TDM par les solutions NGN c'est à dire raccorder les régions comme le grand Nord , le Sud , l'Est ,l'ouest qui manquent aux NGN ZTE ou HAWEI

q Remplacement des DSLAM qui n'offrent que des services XDSL par des MSAN qui peuvent fournir à la fois des services POTS (voix simple), XDSL dans les zones couvertes par le NGN

q Raccordement des NGN ZTE et HAWEI

q Doter les softswich ZTE et HAWEI des serveurs d'application de la TOIP pour la facturation des appels TOIP ou des cartes VOIP H323 ou SIP comme dans le cas du softswich NSOFT du CTI

q Insérer dans les MSAN qui sont les équipements d'accès les cartes TOIP afin d'assurer l'accès à la TOIP par les abonnés TOIP

q Concevoir et commercialiser des modems TOIP pour des utilisateurs qui ne voudront pas se séparer de leur ancien téléphone ou qui n'ont pas les moyens de se doter du téléphone IP qui est cher et CT phones IP pour les nomades

q Raccorder les plates formes MTN , ORANGE , et CT phone CDMA à la plate forme NGN par l'intermédiaire des Média Gateway car le Softswich HAWEI est équipé d'une Média Gateway appelée UMG ( Universal Média Gateway ) qui comprend les organes suivants :

- Le C soft X3000 pour se raccorder au CDMA

- Le M soft X3000 pour se raccorder au GSM

- Le soft X3000 pour se rattacher au RTCP

2.2 Au niveau de l'abonné

Nous conseillons les démarches suivantes :

q L'abonné devra se doter des postes IP phone pour des appels TOIP ou acheter le modem TOIP pour adapter le téléphone analogique.

q Dans le cas des entreprises, se doter des IP-PBX qui implémentent des services IP et de commutateurs mais le prix des IP-PBX étant exorbitant, et le remplacement des PBX existants dans les entreprises et fonctionnant sans problème étant parfois inenvisageable nous conseillons les entreprises de maintenir les anciens PBX et de les adapter en IP-PBX

Par l'insertion des cartes passerelle Gateway FXS et Ethernet et d'interconnecter leur site par VPN

2.3 : ARCHITECTURE DE LA SOLUTION TOIP CAMTEL

PLATE FORME SOLUTION PROPOSEE

UGUYG

Figure 33 : PLATEFORME TOIP CAMTEL

Figure 34 adaptation d'un PABX en IP-PBX

CHAP IV

LA TOIP CAMTEL 

OFFRES TECHNIQUES INNOVANTES

Introduction

A la lumière de toutes les informations dont nous disposons à propos du NGN CAMTEL, il est possible d'innover en terme de nouveaux services. CAMTEL proposant plusieurs services suscités, il sera donc question comme nous l'avons annoncé plus haut de proposer la téléphonie sur IP à travers des offres commerciales et techniques ci-dessous :

v Offre aux grandes structures

Ø installation des VPN avec TOIP comme service à valeur ajoutée pour :

§ les entreprises multi sites disposant des PABX ou IP-PBX

§ les ministères de souveraineté comme la défense, l'économie, la sureté nationale qui ont besoin des architectures de sécurité renforcée en même temps que des réseaux de communication simples et unifiés en vue de rendre fluide les communications et interconnecter toutes les délégations régionales

§ Les liaisons spécialisées (LS ) comme la présidence de la république

§ Adaptation des anciens équipements comme des PABX en IP -PBX en vue d'en faire des équipements IP

v Offre aux particuliers

Ø proposition des abonnements VOIP aux abonnés simples qui comprendront un forfait internet permettant de faire en même temps de la téléphonie et les données

Ø Adaptation des téléphones analogiques pour permettre aux abonnés de classe moyenne de faire de la TOIP car les ip phones sont chers

1 Etude de l'offre innovante de TOIP

1.1avantages pour CAMTEL

Cette offre a pour principal avantage la commercialisation plus rapide de l'offre internet proposée par CAMTEL moyennant des forfaits et la commercialisation des équipements TOIP propres à CAMTEL. Avec la conception des téléphones IP mobiles /CDMA, CAMTEL pourrait ouvrir un nouveau marché qui ferrait basculer les parts de marché obtenus par les opérateurs comme MTN et ORANGE à savoir :

MTN 7 millions d'abonnés soit plus de 40% du marché mobile

ORANGE 6 millions d'abonnés soit plus de 37% du marché mobile

Si nous chiffrons la consommation mensuelle des abonnés mobiles GSM à un minimum de 100fr cfa /mois et en considérant que l'offre TOIP/CDMA apporte un minimum de 1 million de clients nous voyons que l'innovation TOIP mobile ferait gagner à CAMTEL 100 millions/mois ce qui permettrait de couvrir aux maximum les dépenses logistiques et engendrerait d'énormes bénéfices.

2 étude de l'offre innovante TOIP aux grandes structures

La TOIP pour les PME et les PMI est une offre très avantageuse car elle sert à la fois à fusionner les réseaux IP et téléphoniques .en proposant donc des VPN avec VOIP CAMTEL sert non pas seulement la téléphonie et l'IP mais aussi la sécurité

2.1 Approche physique et théorique des VPN

Les VPN sont des réseaux privés virtuels en réalité il sagit d'un concept purement fictif qui consiste à interconnecter plusieurs sites d'une structure par des liens virtuels tout en assurant le confidentialité des données à travers internet.

2.1.1 Les protocoles des VPN de CAMTEL

CAMTEL utilise dans sa gamme des routeurs C7200 comme routeurs founisseurs donc P , PE , et des routeurs 600 comme des routeurs clients CE .

Les protocoles de routage utilisés sont les suivants

· OSPF , MPLS, LDP, dans le coeur du réseau

· BGP entre les PE

· EIGRP ou RIP entre les PE et les CE

251659264Le création des VPN est assurée par la création des tables de routage virtuelles VRF sur les routeurs PE. La topologie d'un VPN CAMTEL avec VOIP est la suivante :

Figure 35 : Exemple du VPN du ministère de la défense

1.1.2 Avantages économiques de l'offre innovante de VPN /TOIP

Nous voyons de prime à bord que pour le cas des entreprises multi sites ou des ministères la création des VPN avec VOIP est très recommandée car elle exclut l'obligation d'installer sur chaque site un PABX équipement très couteux dont le prix revient à quelques millions de francs et dont l'installation et la maintenance requièrent beaucoup de technicité.

CAMTEL dispose d'une offre tarifaire pour les entreprises n'ayant pas de PABX permettant ainsi la communication entre les différents employés de l'entreprise cette offre est la suivante

Tableau 9 Tarifs entreprise proposés par CAMTEL

Destination

Tarifs

Appel vers le réseau CAMTEL ( CT-phone ,fixe )

Heures pleines

50fr TTC/mm

Appel vers le réseau CAMTEL ( CT-phone ,fixe )

Heures creuses

25fr TTC/mm

Appel vers les mobiles MTN et ORANGE

82fr TTC /mm

SMS de CT-phone vers CT-phone

20fr TTC/mm

SMS de CT-phone vers mobile

45fr TTC/mm

Il en ressort de ce tableau que si l'entreprise souscrit pour un abonnement VPN TOIP et si les abonnements comprennent un forfait internet TOIP les économies sont conséquentes.

3 avantages pour les particuliers

Les tarifs proposés par CAMTEL pour les abonnés simples sont consignés sur le tableau ci-dessous

Tableau 10: tarifs pour simple abonné CAMTEL

Destination

Tarifs

Appel vers le réseau CAMTEL ( CT-phone ,fixe )

Heures pleines

70fr TTC/mm

Appel vers le réseau CAMTEL ( CT-phone ,fixe )

Heures creuses

35fr TTC/mm

Appel vers les mobiles MTN et ORANGE

82fr TTC /mm

SMS de CT-phone vers CT-phone

20fr TTC/mm

SMS de CT-phone vers mobile

45fr TTC/mm

En passant à la VOIP le client gagnera la connexion internet et le cout des appels réduits

4 applications de l'offre innovante de VPN/TOIP CAMTEL : cas du MINESUP

4.1 SIMULATION

La voix, dans le monde numérique, est sujette à de nombreux paramètres qui définissent son fonctionnement ainsi que sa propagation à travers les réseaux et en particuliers les réseaux WAN, tel que le réseau Backbone IP MPLS/VPN de CAMTEL. Dans ce chapitre nous allons émuler le transfert de la voix à travers deux sites d'un VPN minesup et agir sur les différents paramètres de qualité de services pour pouvoir évaluer les performances et ainsi pouvoir définir la configuration optimale pour définir une application VOIP performante

4.2 Logiciels de Simulation

Ø 251661312GNS3

GNS3 est un logiciel d'émulation de routeur Cisco au mode graphique. Ce logiciel permet de simuler matériellement des routeurs 7200, 3600 et 2600... en utilisant l'IOS de Cisco. Il fonctionne avec un outil de supervision des routeurs émulés : Dynagen Ces outils fonctionnent sous Linux et Windows et permettent de simuler des topologies incluant les protocoles de l'IOS (RIP, EIGRP, OSPF,...) et les interfaces associées au routeur (Frame Relay, ATM, MPLS...), il est possible de s'en servir pour tester les fonctionnalités des IOS Cisco ou de tester les configurations devant être déployées dans le futur sur des routeurs réels. [9]

Figure 36 : interface graphique de GNS3

Ø VMware

VMware est un logiciel de virtualisation qui permet d'avoir plusieurs machines avec des systèmes d'exploitation différents qui s'exécutent sur le même ordinateur, celles-ci pouvant être reliés au réseau local avec une adresse IP différente, tout en étant sur la même machine physique. Il est possible de faire fonctionner plusieurs machines virtuelles en même temps, la limite correspondant aux performances de l'ordinateur hôte.

Figure 37 : Interface graphique de VMware

Ø TRIXBOX

Trixbox est un ensemble d'outils et d'utilitaires de télécommunication compilés pour devenir un véritable IP PBX. Les principales caractéristiques de TRIXBOX sont :

· Asterisk : le coeur du système téléphonique gestion des relations clients

· A2Billing - Calling Card platform (tarification des appels)

· Flash Operator Panel, a screen-based operator's console Web conférence Outils de configuration utilisateurs de Trixbox [11]

TRIXBOX est utilisé entant que serveur de téléphonie sur IP. Il doit être associé aux clients que sont les téléphones IP ou les soft phones

Figure 38 : interface graphique de TRIXBOX

4.3 Présentation de la maquette de simulation

Dans cette partie nous choisissons de simuler les appels passés par deux employés du MINESUP l'un à Yaoundé et l'autre à Maroua à l'ISS . Les deux sites MINESUP sont raccordés par un VPN constitué de part et d'autre d'un routeur CE , les deux CE sont reliés au coeur du réseau IP/MPLS par deux routeurs PE et les PE sont raccordés par un routeur P. le routeur P est un routeur Cisco 7200 avec l'IOS c7200-js-mz.124-10 ; les deux PE : routeurs provider Edge sont des routeurs Cisco 3660 ainsi que les deux CE routeurs Customer Edge 3660 tous intègrent l'IOS c3660-jk9os-mz.124-1.

Nous allons dans cette partie simuler le cas où pour des besoins de sécurité le MINESUP souscrit à un abonnement VPN /TOIP

Figure 39: maquette de simulation conçue sur GNS3

4. 4 Configuration de la maquette

La configuration de la maquette pour le cas du MINESUP s'est opérée en plusieurs étapes à savoir :

· Etablissement d'un plan d'adressage

· Configuration des routeurs

251660288

v Pour le routeur P

· Configuration du routage classique

· Configuration du routage OSPF

· Activation du routage MPLS

v Pour les routeurs PE

· Configuration du routage classique

· Configuration du routage OSPF

· Configuration du routage MPLS

Ø Configuration du VPN entre le site de Yaoundé et celui de Maroua

· Création des tables de routage virtuelles VRF sur les routeurs PE

· Configuration du protocole BGP entre les PE

· Configuration du protocole EIGRP entre les PE et les CE

· Redistribution de BGP dans EIGRP

· Redistribution d'EIGRP dans BGP

v Pour les CE

· Configuration du routage classique

· Configuration du routage EIGRP

· Configuration de la TOIP sur la maquette

· Création des machines virtuelles sur Vmware (deux clients SIP et un serveur TRIXBOX

· Interconnexion de Vmware avec GNS3

· Configuration des machines virtuelles à savoir :

- Installation des systèmes d'exploitation Windows xp version tiny-tux sur les deux clients

- Configuration du serveur de téléphonie sur IP TRIXBOX et création des comptes utilisateurs

- Configuration des téléphones soft phones x-lite

4-4-1 configurations des routeurs [10]

Routeur P1

P1>en

P1#config t

P1(config)#en secret cisco

P1(config)#line console 0

P1(config-line)#password tri

P1(config-line)#login

P1(config-line)#exit

CONFIGURATION DE L INTERFACE DE LOOPBACK

P1(config)#inter loopback 0

P1(config-if)#ip address 1.1.1.1 255.255.255.0

P1(config-if)#no sh

P1(config-if)#inter f1/0

P1(config-if)#ip address 192.168.12.1 255.255.255.0

P1(config-if)#no sh

P1(config-if)#inter f1/1

P1(config-if)#ip address 192.168.13.1 255.255.255.0

P1(config-if)#no sh

CONFIGURATION DE OSPF [13]

P1(config-if)#router ospf 1

P1(config-router)#router-id 1.1.1.1

P1(config-router)#network 192.168.12.0 0.0.0.255 area 0

P1(config-router)#network 192.168.13.0 0.0.0.255 area 0

P1(config-router)#network 1.1.1.0 0.0.0.255 area 0

P1(config-router)#exit

P1(config)#inter loopback 0

P1(config-if)#ip ospf network point-to-point

P1(config-if)#exit

ACTIVATION DE MPLS

P1(config)#ip cef

P1(config)#mpls label protocol ldp

P1(config)#inter f1/0

P1(config-if)#mpls ip

P1(config-if)#inter f1/1

P1(config-if)#mpls ip

P1(config-if)#exit

P1(config)#mpls ldp router-id loopback 0

ROUTEUR PE1

P1(config)#exit

PE1>en

PE1#config t

PE1(config)#en secret cisco

PE1(config)#line console 0

PE1(config-line)#password tri

PE1(config-line)#login

PE1(config-line)#exit

PE1(config)#inter loopback 0

PE1(config-if)#ip address 2.2.2.2 255.255.255.0

PE1(config-if)#no sh

PE1(config-if)#inter f1/0

PE1(config-if)#ip address 192.168.12.2 255.255.255.0

PE1(config-if)#no sh

PE1(config-if)#inter f1/1

PE1(config-if)#ip address 192.168.24.2 255.255.255.0

PE1(config-if)#no sh

PE1(config-if)#exit

CONFIGURATION DE OSPF

PE1(config)#router ospf 1

PE1(config-router)#router-id 2.2.2.2

PE1(config-router)#network 192.168.12.0 0.0.0.255 area 0

PE1(config-router)#

Detection du routeur P1

00:38:01: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet1/0 from LOADING to FULL, Loading Done

PE1(config-router)#network 2.2.2.2 0.0.0.255 area 0

PE1(config-router)#passive inter

PE1(config-router)#passive-inter

PE1(config-router)#passive-interface f1/1

PE1(config-router)#exit

PE1(config)#inter loopback 0

PE1(config-if)#ip ospf network point-to-point

PE1(config-if)#exit

ACTIVATION DE MPLS

PE1(config)#mpls ldp router-id loopback 0

PE1(config)#ip cef

PE1(config)#mpls label protocol ldp

PE1(config)#inter f1/0

PE1(config-if)#mpls ip

PE1(config-if)#

Detection du voisin mpls 1.1.1.1

00:59:54: %LDP-5-NBRCHG: LDP Neighbor 1.1.1.1:0 is UP

PE1(config-if)#exit

PE1(config)#mpls ldp router-id loop

PE1(config)#mpls ldp router-id loopback 0

Creation du VPN MINESUP

PE1(config)#ip vrf MINESUP

PE1(config-vrf)#rd 100:1

PE1(config-vrf)#route-target both 1:100

PE1(config-vrf)#inter f1/1

PE1(config-if)#ip vrf forwarding MINESUP

PE1(config-if)#ip address 192.168.24.2 255.255.255.0

PE1(config-if)#no sh

PE1(config-if)#exit

CONFIGURATION DU ROUTAGE BGP

PE1(config)#router bgp 1

PE1(config-router)#neighbor 3.3.3.3 remote-as 1

PE1(config-router)#neighbor 3.3.3.3 update-source looopback 0

PE1(config-router)#neighbor 3.3.3.3 update-source loopback 0

PE1(config-router)#address-family vpnv4

PE1(config-router-af)#neighbor 3.3.3.3 activate

PE1(config-router-af)#neighbor 3.3.3.3 send community both

PE1(config-router-af)#neighbor 3.3.3.3 send-community both

PE1(config-router-af)#exit

PE1(config-router)#exit

CONFIGURATION DU ROUTAGE EIGRP ENTRE PE1 ET CE1

PE1(config)#router eigrp 1

PE1(config-router)#address-family ipv4 vrf MINESUP

PE1(config-router-af)#autonomous-system 100

PE1(config-router-af)#network 192.168.24.0

Detection du CE1 par PE1

01:34:00: %DUAL-5-NBRCHANGE: IP-EIGRP(1) 100: Neighbor 192.168.24.4 (FastEthernet1/1) is up: new adjacency

01:39:57: %DUAL-5-NBRCHANGE: IP-EIGRP(1) 100: Neighbor 192.168.24.4 (FastEthernet1/1) is resync: summary configured

Redistribution de bgp dans eigrp

PE1(config-router-af)#redistribute bgp 1 metric 1500 4000 200 10 1500

PE1(config-router-af)#exit

PE1(config-router)#exit

Redistribution de eigrp dans bgp

PE1(config)#router bgp 1

PE1(config-router)#address-f

PE1(config-router)#address-family ipv4 vrf MINESUP

PE1(config-router-af)#redistribute eigrp 100

PE1(config-router-af)#exit

PE1(config-router)#exit

Detection des voisins

01:48:40: %BGP-5-ADJCHANGE: neighbor 3.3.3.3 Up

01:50:26: %BGP-5-ADJCHANGE: neighbor 3.3.3.3 Down Peer closed the session

ROUTEUR PE2

01:50:31: %BGP-5-ADJCHANGE: neighbor 3.3.3.3 Up

PE2>en

PE2#config t

PE2(config)#en secret cisco

PE2(config)#line console 0

PE2(config-line)#password tri

PE2(config-line)#login

PE2(config-line)#exit

PE2(config)#inter loopback 0

PE2(config-if)#ip address 3.3.3.3 255.255.255.0

PE2(config-if)#no sh

PE2(config-if)#inter f1/0

PE2(config-if)#ip address 192.168.13.3 255.255.255.0

PE2(config-if)#no sh

PE2(config-if)#inter f1/1

PE2(config-if)#ip address 192.168.35.3 255.255.255.0

PE2(config-if)#no sh

PE2(config-if)#exit

CONFIGURATION DE OSPF

PE2(config)#router ospf 1

PE2(config-router)#router-id 3.3.3.3

PE2(config-router)#network 192.168.13.0 0.0.0.255 area 0

Detection du voisin 1.1.1.1

00:46:45: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on FastEthernet1/0 from LOADING to FULL, Loading Done

PE2(config-router)#network 3.3.3.3 0.0.0.255 area 0

PE2(config-router)#passive-interface f1/1

PE2(config-router)#exit

PE2(config)#inter loopback 0

PE2(config-if)#ip ospf network point-to-point

PE2(config-if)#exit

ACTIVATION DE MPLS

PE2(config)#ip cef

PE2(config)#mpls label protocol ldp

PE2(config)#inter f1/0

PE2(config-if)#mpls ip

Detection du voisin

00:51:43: %LDP-5-NBRCHG: LDP Neighbor 1.1.1.1:0 is UP

PE2(config-if)#exit

PE2(config)#mpls ldp router-id loopback 0

Creation du VPN MINESUP

PE2(config)#ip vrf MINESUP

PE2(config-vrf)#rd 100:1

PE2(config-vrf)#route-target both 1:100

PE2(config-vrf)#inter f1/1

PE2(config-if)#ip vrf forwarding MINESUP

PE2(config-if)#ip address 192.168.35.3 255.255.255.0

PE2(config-if)#no sh

PE2(config-if)#exit

CONFIGURATION DU PROTOCOLE BGP

PE2(config)#router bgp 1

PE2(config-router)#neighbor 2.2.2.2 remote-as 1

PE2(config-router)#neighbor 2.2.2.2 update-source loopback 0

PE2(config-router)#address-f

PE2(config-router)#address-family vpnv4

PE2(config-router-af)#neighbor 2.2.2.2 activate

PE2(config-router-af)#neighbor 2.2.2.2 send-community extended

PE2(config-router-af)#exit

PE2(config-router)#

PE2(config-router)#exit

CONFIGURATION DE EIGRP

PE2(config)#router eigrp 1

PE2(config-router)#address-family ipv4 vrf MINESUP

PE2(config-router-af)#autonomous-system 100

PE2(config-router-af)#network 192.168.35.0

PE2(config-router-af)#no auto-summary

DISTRIBUTION DE BGP DANS EIGRP

PE2(config-router-af)#redistribute bgp 1 metric 1500 400 20 20 1500

PE2(config-router-af)#router bgp 1

REDISTRIBUTION DE EIGRP

PE2(config-router)#address-family ipv4 vrf MINESUP

PE2(config-router-af)#redistribute eigrp 100

PE2(config-router-af)#exit

PE2(config-router)#exit

ROUTEUR CE1

CE1>en

CE1#config t

CE1(config)#en secret cisco

CE1(config)#line console 0

CE1(config-line)#password tri

CE1(config-line)#login

CE1(config-line)#exit

CE1(config)#inter loopback 0

CE1(config-if)#ip address 4.4.4.4 255.255.255.0

CE1(config-if)#no sh

CE1(config-if)#inter f1/0

CE1(config-if)#ip address 192.168.24.4 255.255.255.0

CE1(config-if)#no sh

CE1(config-if)#inter f1/1

CE1(config-if)#ip address 192.168.40.4 255.255.255.0

CE1(config-if)#no sh

CE1(config-if)#exit

CONFIGURATION DE EIGRP

CE1(config)#router eigrp 100

CE1(config-router)#network 192.168.24.0

CE1(config-router)#network 4.4.4.0

CE1(config-router)#network 192.168.40.0

CE1(config-router)#no auto-summary

CE1(config-router)#exit

ROUTEUR CE2

CE2>en

CE2#config t

CE2(config)#en secret cisco

CE2(config)#line console 0

CE2(config-line)#password tri

CE2(config-line)#login

CE2(config-line)#exit

CE2(config)#inter loopback 0

CE2(config-if)#ip address 5.5.5.5 255.255.255.0

CE2(config-if)#no sh

CE2(config-if)#inter f1/0

CE2(config-if)#ip address 192.168.35.5 255.255.255.0

CE2(config-if)#no sh

CE2(config-if)#no sh

CE2(config-if)#inter f1/1

CE2(config-if)#ip address 192.168.50.5 255.255.255.0

CE2(config-if)#no sh

CONFIGURARION DE EIGRP ENTRE CE2 ET PE2

CE2(config-if)#exit

CE2(config)#router eigrp 100

CE2(config-router)#network 192.168.35.0

CE2(config-router)#network 192.168.50.0

CE2(config-router)#network1 5.5.5.0

CE2(config-router)#network 5.5.5.0

CE2(config-router)#no auto-s

CE2(config-router)#no auto-summary

CE2(config-router)#exit

4.4.2 Conception et configuration des machines virtuelles

La conception des machines virtuelles se fait à l'aide de VMware ou virtual BOX dans notre cas nous avons utilisé Vmware pour créer trois machines virtuelles

Deux ayant le système XP qui seront les clients et une dans laquelle il y aura le serveur TRIXBOX

4.4.3 Connexion des machines virtuelles de VMware avec la maquette de GNS3

Les trois machines de Vmware seront connectées à GNS3 par des cartes réseau virtuelle VMnet 0 , VMnet 1, VMnet2 choisies dans GNS3 et connectées en mode Custom dans VMware

Figure 40:interface présentant les cartes réseaux virtuelles sur GNS3

4.5 Configuration des comptes sur TRIXBOX

TRIXBOX n'ayant pas d'interface graphique les comptes seront configurés à partir des machines clientes en tapant l'adresse du serveur TRIXBOX dans la barre de navigation

Figure 41 :l'interface de TRIXBOX

Figure 42 : création des comptes utilisateur sur le serveur trixbox

4.6 Configuration des soft phones

Les soft phones sont configurés en utilisant les mêmes propriétés des comptes crées dans trixbox

Figure 43:configuration des soft phones

La maquette MINESUP étant toute configurée on passe alors aux tests

Dans le chapitre qui suivra nous mettrons en relief les résultats et les commentaires

CHAP V

RESULTATS ET COMMENTAIRES

1 .vérification de l'implémentation des protocoles de routage OSPF BGP LDP EIGRP

On vérifiera l'implémentation des protocoles de routage à l'aide du logiciel WIRESHARK qui permettra de capturer les trames de données dans le réseau

1.1 Vérification d'OSPF

En capturant les trames qui circulent entre P1 et PE1 on a :

Figure 44 : trafic entre P1etPE1

1.2 Vérification de BGP

Entre P1 et PE2 on a :

Figure 45:trafic entre P1 et PE2

1.3 Vérification d'EIGRP

Entre PE1 et CE1 on a :

Figure 46: trafics entre PE1 et CE1

1.4 Vérification de MPLS à travers LDP

Figure 47:protocole LDP capturé dans les trames

2. vérification de la bonne implémentation de la TOIP dans le VPN /TOIP

MINESUP

Figure 48:téléphone-IP du MINESUP/ YDE affichant son numéro

Figure 49 : Téléphone -IP de la délégation régionale du MINESUP de l'extrême Nord UMA/ISS affichant son numéro

Figure 50 : capture de la signalisation SIP entre le serveur et MINUSUP/ISS

3. Commentaires

Nous remarquons que entre les routeurs P1 , PE1 et PE2 lords du scan du réseau par Wireshark il est impossible d'observer les paquets SIP car le VPN les rend transparents

Le VPN est donc un puissant moyen de sécurité

Avec Wireshark on obtient le courbe de trafic suivante

Figure 51: courbe de trafic du VPN /TOIP MINESUP

4 Conclusion et perspectives

La TOIP est une technologie d'avant-garde car à la vue de ces principaux avantages à savoir son moindre coût , sa sécurité , sa mobilité à travers l'implémentation du protocole IPV6 , ses options innovantes tels que la messagerie unifiées , la vidéoconférence, il n'en demeure pas moins que son implémentation et sa commercialisation par un opérateur comme CAMTEL revêt d'un véritable défi car la TOIP n'est pas standardisée . En effet, les protocoles de signalisation tel SIP et H323 n'ont pas encore de standard commun de plus la TOIP bien que permettant d'appeler à moindre coût nécessite par conséquent pour le client un matériel de pointe à savoir les téléphones IP chers et non accessibles à toutes les classes sociales de la population . néanmoins avec l'avancé de la technologie il est à prévoir des offres plus que modestes du matériel de TOIP à moindre coût ce qui aurait pour but d'opérer un véritable big-bang dans le monde de la téléphonie où tout sera maintenant IP on parlera alors de communications unifiées voix/vidéo .

Pour atteindre ce cap, le réseau IP préalablement conçut pour les applications dont le temps de latence et de gigue n'est pas tellement prioritaire devrait être modifié afin de permettre les applications temps réels comme la TOIP car dans l'exemple de la simulation ci-dessous nous remarquons que la courbe de trafic n'atteint pas son maximum cela entraine sur le réseau une gigue et une latence importante .

Nous pouvons également prévoir face à la demande de ce service de VPN/TOIP les qualités de mobilité et un besoin accru d'adresse publique

Raison pour laquelle face à ces problèmes nous proposons les solutions suivantes :

v Pour le routage et la QOS

La résolution de ces problème passe par :

Ø La configuration de l'ingénierie de trafic MPLS-TE par le protocole RSVP créant ainsi un tunnel dynamique entre les PE [14]

Ø La configuration de la qualité de service pour soulager le routage au coeur du réseau en utilisant le protocole QOSPF

Ø La configuration de la QOS pour les services voix en utilisant le model DIFSERV qui classera les paquets voix par classe et non par flux comme dans le cas de INTSERV cela aura pour but un routage prioritaire des paquets voix qui ont des contraintes de transmission temps réel.

v Pour la mobilité, la sécurité des abonnés n'appartenant pas à un VPN

Ø Implémentation du protocole IPV6 qui offre en outre la sécurité à travers IPsec et la mobilité car IPV6 permet de conserver une même adresse IP et de pouvoir se déplacer dans tout le monde entier en la conservant

Ø IPV6 permettra aussi à la longue de résoudre le problème de la téléphonie-IP mobile car la téléphonie mobile en très grande expansion nécessite un très grand nombre d'adresses IP .

BIBLIOGRAPHIE

[1] Le Réseau Téléphonique Commuté Fixe : Pascal Mouchard 2010/2011. [2] Point sur l'internet et la téléphonie mobile au Cameroun : par Salomon MAHAMA Université de Yaoundé I - DEA Informatique 2008. [3] Nouvelles technologies réseau-ADSL : école d'ingénieurs 2000 université de Marne-la-vallée. [4] intégration d'un nouveau Broad band Access serveur pour la terminaison des sessions ADSL sur le backbone IP SONATEL : par Tafsir Mouhamadou Lamine Fall. [5] Techniques, environnement et services de visioconférence IP : Guy.Bisiaux JRE S2003 LILLE.

[6] La VOIP dans la gamme des services de Camtel : Manfouo Herman .IAI Cameroun. [7] Mise en oeuvre d'un coeur de réseau IP/ MPLS : par Amine Amine
Université de Bechar  - Technicien supérieur de maintenance de réseaux 2011 [8] Ingénierie des MSAN (Multi Service Access Node) : par Med Zakaria ELQASMI Ecole marocaine des sciences de l'ingénieur (EMSI)  Ingénieur 2010

[9] intégration des services voix sur la dorsale IP/MPLS de CAMTEL par AKONO MVONDO ENSP YDE

[10] Configuration VPN : Cisco CCNA Security Lab.

[11] TP ,QoS ,VoIP & TrixBox : par Guillaume FAHRNER et Alexandre LAFARCINADE

[12] Mise en place d'IPV6 : par CYRILLE DUFRESNE

[13] configuration des protocoles de routage : WWW .MAROC.COM

[14] MPLS : par Benbella Benduduh et Jean Marc Fourcade






Bitcoin is a swarm of cyber hornets serving the goddess of wisdom, feeding on the fire of truth, exponentially growing ever smarter, faster, and stronger behind a wall of encrypted energy